openBCMのmakeで悩む2022/03/12 22:30

久し振りにmakeしたら,「ldが互換性のない libcrypt.so をスキップしました」とエラーを吐いたが,libxcrypt-devel-32bitを追加したら解消した。でも,スッキリしない 😒

$ ldd out-x86_64/bcm | grep libcrypt
 	libcrypt.so.1 => /usr/lib/libcrypt.so.1 (0xf7f4e000)
$ rpm -qf /usr/lib/libcrypt.so.1
libcrypt1-32bit-4.4.15-2.51.x86_64 
$ rpm -ql libcrypt1-32bit | grep libcrypt.so
/usr/lib/libcrypt.so.1
/usr/lib/libcrypt.so.1.1.0
$ rpm -ql libxcrypt-devel-32bit | grep libcrypt.so
/usr/lib/libcrypt.so
$ ls -l /usr/lib/libcrypt.so*
lrwxrwxrwx 1 root root     17  5月  7  2021 /usr/lib/libcrypt.so -> libcrypt.so.1.1.0
lrwxrwxrwx 1 root root     17  5月  7  2021 /usr/lib/libcrypt.so.1 -> libcrypt.so.1.1.0
-rwxr-xr-x 1 root root 222604  5月  7  2021 /usr/lib/libcrypt.so.1.1.0

本日の衛星: HO-113で交信。